2008年06月29日

MT4で mt-check.cgiが見つかりませんでした。エラー

4.12が出てることだし、
そろそろMovableType4.12でCMSなんかやってみようかと、自鯖にインストールしてみたのですが、
一部動かない機能が判明。
インストール自体は問題なかったのですが、以下の機能がエラーとなった

1.「システムメニューのツール - システム情報」でエラー
以下のエラーが出る

mt-check.cgiが見つかりませんでした。
mt-check.cgiが存在すること、
名前を変えた場合は構成ファイルのCheckScriptディレクティブに名前を指定してください。

mt-check.cgi直であればちゃんと動作します
CMS.pmも検索し、変数もチェックしましたが、URIは合っていた


2.「ブログメニューのスタイル - デザイン - スタイル」の既存以外のスタイル選択でエラー
以下のエラーが出る

テーマの読み込みでエラーが発生しました! -- URLが不正です: http://www.sixapart.com/movabletype/styles/mt4/library

要するにStypeChatcherのところです
コチラはAjaxと連携していてわけわかめ


散々検索しても、障害はあるものの、それらしき解決策はみつからず

システム情報のソース(CMS.pm)を見ていたとき、もしやHTTP:*が動いてないんじゃないかと。。。
テストプログラムを作成したところ、HTTP:*モジュールが機能してない事が判明
というか、
LWP(p5-libwww)インストールしてねぇ!
という結論に至りました。
LWP(p5-libwww)インストールで全て解決

mt-check.cgiでこれもチェックしてほしかったわー_no
posted by sanahi at 01:44| 滋賀 ☔| Comment(3) | TrackBack(1) | Software | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
僕も「テーマの読み込みでエラーが発生しました!」エラーが出ておりましてどうにも困っております。

LWP(p5-libwww)とはなんでしょう?
perlのモジュールですか?
よろしければ具体的インストール方法を教えていただけないでしょうか。
Posted by う at 2008年07月26日 15:55
Perlのモジュールですよー
FreeBSDならPortsからInstallできます
/usr/ports/www/p5-libwww
あたりだったとおもいます
Posted by sanahi at 2008年07月27日 19:04
ありがとうございます。

私はCentOS5を使用しておりますが、
調べてみたいと思います!
Posted by う at 2008年08月04日 11:14
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。

この記事へのトラックバック

MT4に代えてからテンプレートライブラリが見れない件
Excerpt:  専用サーバに移行するときにMTを4にアップしましたがそれ以来使えていないテンプ...
Weblog: ♪8th Note♪
Tracked: 2008-10-27 00:12

Remarks
記事中にソースコードが含まれる場合、ソースコードの再利用、改変、「オレのものにする」等は自由ですが、
ソースコードを利用して起こった問題は一切責任を負いません。(自己責任での利用となります。)